Magento 1.9 Admin: No region found within the locale 'de'

Vor kurzem hatte ich ein sehr seltsames Verhalten in einem Magento-Shop mit Version 1.9:

  • Die Admin-Sprache wurde nach dem Login immer wieder auf Englisch gestellt
  • Ich konnte keine Veränderungen an den Locale-Einstellungen fürs Frontend machen (alles sprang immer wieder auf Afrikaans und eine ganz andere Zeitzone) - als Workaround habe ich die Einstellungen in der Website überschrieben, das ging komischerweise
  • Mit dem Firefox konnte ich keine Produkte bearbeiten, da ich immer wieder den Fehler "No region found within the locale 'de'" bekam (liegt sicher an der übertragenen Locale, Firefox überträgt hier nicht "de_DE", sondern nur "de")

Lösung

Aus irgend einem Grund, hat sich in die Tabelle core_config_data ein seltsamer Eintrag eingeschlichen, welcher als Pfad einfach nur "general" hatte, und den Wert NULL. Macht insgesamt natürlich wenig Sinn und kann ohne Gefahr gelöscht werden. Und siehe da: Alle oben genannten Probleme waren mit einem Schlag gelöst! Falls Ihr also Probleme mit den Locale-Einstellungen im Admin habt, kontrolliert einfach als erstes die Konfigurationstabelle. Kleines Problem, große Wirkung.


Ein Beitrag von Matthias Kleine
Matthias's avatar

Matthias Kleine hatte Mitte 2012 die ersten Kontakte mit Magento - dies geschah durch die Anstellung bei der code-x GmbH als Softwareentwickler. Seit dem bildet er sich ständig im Bereich eCommerce fort, schreibt eigene Extensions und stellt diese gerne auch als OpenSource-Projekte auf GitHub zur Verfügung. Seit Ende 2013 wird Matthias auch im Verzeichnis der zertifizierten Magento-Entwickler gelistet. @klein0r

Alle Beiträge von Matthias

Dein Kommentar